HomeBrew install

#**Homebrew** install
/bin/bash -c "$(curl -fsSL <https://raw.githubusercontent.com/Homebrew/install/master/install.sh>)"
OR
ruby -e "$(curl -fsSL <https://raw.githubusercontent.com/Homebrew/install/master/install>)" 2> /dev/null
enter
#add path to brew
echo 'eval $(/opt/homebrew/bin/brew shellenv)' >> /Users/clevergod/.zprofile
eval $(/opt/homebrew/bin/brew shellenv)

#Soft instal with **brew**
brew install zsh
chsh -s /bin/zsh
brew install burp
etc...

CalNCService eat many CPU

rm -rf ~/Library/Caches/* && rm -rf ~/Library/Containers/com.apple.Calendar* && pkill CalendarAgent

poc.inetlock

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "<http://www.apple.com/DTDs/PropertyList-1.0.dtd>">
<plist version="1.0">
  <dict>
    <key>URL</key>
    <string>FiLe:////////////////////////System/Applications/Calculator.app</string>
  </dict>
</plist>

Disable app singn

sudo spctl --master-disable
sudo chmod -R 755 Opera.app

brew install upx
brew install --build-from-source upx
sudo upx -d /Applications/Opera.app/Contents/MacOS/Opera

Report crash high CPU usage

To disable crash reporting:
launchctl unload -w /System/Library/LaunchAgents/com.apple.ReportCrash.plist
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.ReportCrash.Root.plist

To enable crash reporting:
launchctl load -w /System/Library/LaunchAgents/com.apple.ReportCrash.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.ReportCrash.Root.plist

Most Links

Как исправить высокую нагрузку на ЦП процессом WindowServer - MacSecurity

#MacOS

sublime-text

GitHub - its-a-feature/offensive_macos: Tracking of offensive macOS tooling, blogs, and related helpful information

Homebrew: How to install reconnaissance tools on macOS

Похек Wi-Fi встроенными средствами macOS

GitHub - D00MFist/Mystikal: macOS Initial Access Payload Generator